Arkadaşlar merhaba;

Size bu yazımızda WordPress’in son güncellemesi versiyon 5.0 ile ilgili detayları ve özellikleri anlatacağım. Yazıya başlamadan önce WordPress’i henüz duymamış bilmeyen arkadaşlar için çok kısa WordPress’ten bahsetmek istiyorum.

Kısaca WordPress;

WordPress en basit açıklama ile kendi web sitenizi oluşturmanın en hızlı ve en popüler yoludur. Son açıklamalara göre websitelerinin % 32’sinden fazlasında WordPress altyapısı kullanılmaktadır. Yani ziyaret ettiğiniz dört web sitesinden her biri WordPress ile oluşturulmuştur. Daha teknik bir düzeyde açıklamak gerekirse, WordPress, GPLv2 altında lisanslanan açık kaynaklı bir içerik yönetim sistemidir (CMS); bu, herkesin WordPress yazılımını ücretsiz olarak kullanabileceği, değiştirebileceği ya da geliştirebileceği anlamına gelmektedir. WordPress, yazılım bilmeyen kişilerin dahi basit bir blog web sitesi yapabilmesini amaçlamaktadır. Biraz kodlama biliyorsanız WordPress ile yapamayacağınız websitesi yoktur. Görsel olarak da WordPress harika sonuçlar vermektedir.

WordPress 5.0 Nedir

WordPress geçtiğimiz günlerde yeni bir sürüm yayınladı ve WordPress 5.0 da bu sürümün adıdır. Bu versiyona Küba Caz Sanatçısı Bebo Valdez’i onurlandırmak adına da lakap olarak Bebo adı verilmiştir. Bu versiyonun en büyük özelliği yeni editör olmuştur. Gutenberg editörü daha önce eklenti olarak WordPress içerisinde yer almaktaydı. Fakat o eklenti için daha çok beta sürüm demek daha doğru olur. Zaten eklenti puanlamalarında da 2,9 yıldıza sahip, bir çok eleştiriler alan bir durumu vardı. WordPress geliştiricileri kullanıcıların tüm eleştiri, görüş ve şikayetlerini ele aldığı , sorunların çözümü için oldukça başarılı bir şekilde çalıştığı açıkça görülüyor. WordPress 5.0 içerisinde bulunan Gutenberg editör ile daha önce eklenti olarak bulunan editör arasında gözle görülen ve kullanımlarda açıkça hissedilen değişiklikler olmuş. Öncelikle kullanımı daha kolay hale getirilmiş (eski editöre alışmış kullanıcılar için ilk birkaç içerik girmek sıkıntı olsa da alışılması oldukça kolay), yavaşlık sorunları giderilmiş ve az sonra değineceğimiz güvenlik açıkları konusu da Gutenberg editörde hassas davranılmış. Bazılarımız klasik editörden kopmak istemeyecektir merak etmeyin Gutenberg editörü kullanmak mecburi değil eski klasik editörü kullanmaya devam edebileceksiniz 🙂 Yeni editör hakkında daha fazla bilgi için WordPress’in Gutenberg sayfasına göz atabilirsiniz.

Gutenberg editörde bir blok oluşturmak için enter tuşuna basmanız yeterli olacaktır. Her bloğu kendi içinde paragraf, yazı, resim ve diğer tüm özellikleri kullanabilir, özgünleştirebilirsiniz. Bu editörü kullanırken bazı kısayolları bilmenizde fayda var. Kullanım sırasında bu kısayollar hem zaman hem de pratiklik kazanmanıza yardımcı olacaktır. İşte o kısayollar;

Blok Duplike Etme: Ctrl + Shift
Seçilen Bloğu Silme: Shift + Alt + Z •
Yeni Blok Ekleme(Öncesine): Ctrl + Alt + T
Yeni Blok Ekleme(Sonrasına): Ctrl + Alt + Y
Blok Türünü Değiştirme: – / + “Blok Adı”
Tüm Blokları Seçme: Ctrl + A
Blok İçeriğini Seçme: Ctrl + A x2
Seçimi İptal Etme: Esc
Link Ekleme: Ctrl + K
Kalın Yapma: Ctrl + B
İtalik Yapma: Ctrl + I
Altı Çizili Yapma: Ctrl + U
Üstü Çizili Yapma: Shift + Alt + 0
Tek Boşluklu Yapma: Shift + Alt + X
İçeriği Kaydetme: Ctrl + S
Toolbar’ı Gösterme/Gizleme: Ctrl + Shift
Görsel ve HTML Editör Arasında Geçiş Yapma: Ctrl + Shift + Alt
Son Değişikliği Geri Alma: Ctrl + Z
Son Değişikliği Geri Verme: Ctrl + Shift + Z
Blok Navigasyon Menüsünü Açma: Shift + Alt + 0
Sıradaki Bloğu Taşıma: Ctrl + veya Shift + Alt + N

Güvenlik Açıkları Güncellemesi;

WordPress geçen yılki güncellemeden sonra özellikle Rest API tarafında yaşanan sorunlar ve güvenlik açıkları problemlerini Wordpres 5.0 ile kapatmış durumda. Ayrıca Rest API’de yapılan değişiklikler ile web sitenizden veri göndermeyi ve çekmeyi kolaylaştırarak, geliştiricilerin daha zengin özelliklere sahip içerikler/ürünler oluşturmasına yardımcı olur. Bu güncelleme, geliştiricilerin platformu bir çerçeve olarak kullanarak uygulamaları daha kolay oluşturabilecekleri anlamına gelir. Bu özellik ile özel temalar oluşturmak daha kolay hale gelir. Rest API ve Gutenberg editöründeki bu değişiklikler daha az eklenti kullanılmasını sağlaması bekleniyor. Böylece WordPress’in kendi dosyaları haricinde kullanıcılar ve geliştiriciler tarafından kaynaklanabilecek güvenlik açıkları riski de en aza inmesi bekleniyor.

WordPress güncellemelerinden dolayı yaşayabileceğiniz güvenlik sorunları için bizimle iletişime geçebilirsiniz.

Yeni Tema : Yirmi Ondokuz

Aslında bu bir WordPress klasiği her sene Aralık ayına yeni girilecek yıla yeni bir tema. Yirmi Onsekiz, Yirmi Onyedi gibi bu yıl da Yirmi Ondokuz çıktı. Yirmi Ondokuz’da en öne çıkan yenilik Yirmi Onyedi ve Yirmi Onsekiz’de yaşadığımız yavaşlık sorunu çözülmüş gibi duruyor. Diğer eski yıl temalarına göre daha modern bir tema ve yeni editöre tam uyumluluk içinde. Aşağıda uyarılar ve tavsiyeler bölümünde yazsam da yeri gelmişken belirtmek isterimki Gutenberg editörünü önce Yirmi Ondokuz temasında deneyin, test edin. Şu an için yeni editöre en uygun tema WordPress 5.0 güncellemesi ile beraber gelen Yirmi Ondokuz’dur.

WordPress 5.0 güncellemesi ve getirdikleri genel olarak bunlar arkadaşlar. Tabii ki ufak tefek güncellemeler gelecektir, bazı eksik kalan yanlar ve değişiklikler olacaktır. Bunlarda geldikçe yeni yazılarımızda yayınlamaya devam edeceğiz.
WordPress 5.0 nasıl edinirim diyen arkadaşlarımız için iki yöntem mevcuttur;

  1.  www.wordpress.org\download adresinden indirebilirsiniz. FTP yolu ile güncelleme yapailirsiniz.
  2.  Admin panelinizde bulunan güncellemeler bölümünden yapabilirsiniz.

Uyarılar ve Tavsiyeler

  1. Arkadaşlar her zaman belirttiğim önemli konudur yedek alın. Özellikle bu büyük güncellemeler bazı temalar, bazı sistemler ile sorun yaşayabilirsiniz. Bunun için kesinlikle yedeklerinizi alın.
  2.  Wordpress’in kendi temalarından dahi olsa temanızın yeni güncellemeyi destekleyip desteklemediğini öğrenin. Desteklemiyorsa temanıza kesinlikle güncelleme yapmayın.
  3.  Özellikle Gutenberg editörü kullanımı çok büyük bir değişiklik ve başta site içerik sağlayıcıları merak edecek her yerini kurcalamak isteyecektir. Fakat, bunu en önemli içeriğinizde yada acil yayınlamanız gereken içerikte yapmamanızı öneririm.
  4.  Wordpress güncellemeleri ile ilgili yetkinliğe sahip değilseniz WordPress 5.0 güncellemesini bu işi bilen birilerine yaptırın. Köklü değişiklilerde yapılabilecek bir hata sitenizi bir süre kapalı kalmasına sebep olabilir.
  5. Gutenberg Editör ile Rest API sayesinde birçok kullandığınız eklentiyi kullanma ihtiyacınız kalkacağından ötürü ileride yayınlayacağımız Rest API ve Gutenberg Editör yazılarımızı dikkatle okuyup, zaman içerisinde eklentilerinizi kaldırın. Böylece hem sitenizin yükünü hafifletmiş hem de olası güvenlik açıklarına karşı kendinizi korumaya almış olursunuz.

WordPress 5.0 ile beraber gelen güncellemelerin özellikle içerik sağlayıcılar için çok faydalı olduğunu düşünmekteyim. Gutenberg editörünün getirdiği blok kullanımı ve diğer özellikler ile ilgili yazılarımız www.websitetr.com/blog  sayfalarında devam edecek. Gerek WordPress 5.0’dan ötürü gerekse başka diğer konulardan ötürü yaşayacağınız tüm sıkıntılar için iletişim adresinden bize ulaşabilirsiniz.

Bir başka yazıda görüşmek üzere.